Sunday 25 October 2015

RIP authentication lab

RIP Lab

We will demonstrate in this lab how to configure RIP, the authentication in clear text or in MD5, and how to check it.




R1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down
Serial0/0                  12.1.1.1        YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/1                  unassigned      YES NVRAM  administratively down down
Loopback0                  1.1.0.1         YES NVRAM  up                    up
Loopback1                  1.1.1.1         YES NVRAM  up                    up
Loopback2                  1.1.2.1         YES NVRAM  up                    up
Loopback3                  1.1.3.1         YES NVRAM  up                    up
R1#


R2#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down
Serial0/0                  12.1.1.2        YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/1                  23.1.1.1        YES NVRAM  up                    up
Loopback0                  2.2.4.2         YES NVRAM  up                    up
Loopback1                  2.2.5.2         YES NVRAM  up                    up
Loopback2                  2.2.6.2         YES NVRAM  up                    up
Loopback3                  2.2.7.2         YES NVRAM  up                    up
R2#



Authentication clear text

R1(config)#key chain RIP_CLEAR_TXT
R1(config-keychain)#ke
R1(config-keychain)#key 1
R1(config-keychain-key)#key
R1(config-keychain-key)#key-string CISCO123
R1(config-keychain-key)#int
R1(config-keychain-key)#int serial
R1(config-keychain-key)#int serial0/0
R1(config-if)#ip rip au
R1(config-if)#ip rip authentication ke
R1(config-if)#ip rip authentication key-chain RIP_CLEAR_TXT
R1(config-if)#
R1(config-if)#serial rest
R1(config-if)#serial restart-delay 0
R1(config-if)#do sh ip proto
% Ambiguous command:  "do sh ip proto"
R1(config-if)#do sh ip proto  ____-how to check
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 25 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial0/0             2     2                    RIP_CLEAR_TXT
    Loopback0             2     2
    Loopback1             2     2
    Loopback2             2     2
    Loopback3             2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    12.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update

R1 configuration for MD5

R1(config)#key chain RIP_MD5
R1(config-keychain)#key 1
R1(config-keychain-key)#key
R1(config-keychain-key)#key-string CISCO123
R1(config-keychain-key)#int
R1(config-keychain-key)#int seri
R1(config-keychain-key)#int serial0/0
R1(config-if)#ip rip auth
R1(config-if)#ip rip authentication mode md5
R1(config-if)#ip rip auth
R1(config-if)#ip rip authentication key-
R1(config-if)#ip rip authentication key-chain RIP_MD5

R2

R2(config)#key chain RIP_MD5
R2(config-keychain)#key 1
R2(config-keychain-key)#key
R2(config-keychain-key)#key-string CISCO123
R2(config-keychain-key)#int seir
R2(config-keychain-key)#int serial0/0
R2(config-if)#ip rip auth
R2(config-if)#ip rip authentication mode
R2(config-if)#ip rip authentication mode ?
  md5   Keyed message digest
  text  Clear text authentication
R2(config-if)#ip rip authentication mode md5
R2(config-if)#ip rip auth
R2(config-if)#ip rip authentication key
R2(config-if)#ip rip authentication key-chain RIP_MD5
R2(config-if)#

R1(config-if)#do sh ip proto
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 19 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial0/0             2     2                    RIP_MD5
    Loopback0             2     2
    Loopback1             2     2
    Loopback2             2     2
    Loopback3             2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    12.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    12.1.1.2             120      00:00:09
  Distance: (default is 120)

 Verification


R1# debug ip rip
*Mar  1 00:54:40.147:   34.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 00:54:40.163: RIP: ignored v2 packet from 1.1.3.1 (sourced from one of our addresses)
*Mar  1 00:54:40.703: RIP: received packet with MD5 authentication
*Mar  1 00:54:40.703: RIP: received v2 update from 12.1.1.2 on Serial0/0
*Mar  1 00:54:40.707:      2.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar  1 00:54:40.707:      3.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar  1 00:54:40.711:      4.0.0.0/8 via 0.0.0.0 in 3 hops
*Mar  1 00:54:40.711:      23.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar  1 00:54:40.715:      34.0.0.0/8 via 0.0.0.0 in 1 hops


2#sh run
Building configuration...

Current configuration : 1639 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
key chain RIP_CLEAR_TXT
 key 1
   key-string CISCO123
key chain RIP_MD5
 key 1
   key-string CISCO123
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 2.2.4.2 255.255.255.0
!
interface Loopback1
 ip address 2.2.5.2 255.255.255.0
!
interface Loopback2
 ip address 2.2.6.2 255.255.255.0
!
interface Loopback3
 ip address 2.2.7.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 12.1.1.2 255.255.255.0
 ip rip authentication mode md5
 ip rip authentication key-chain RIP_MD5
 serial restart-delay 0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 23.1.1.1 255.255.255.0
 clock rate 64000
!
router rip
 version 2
 network 2.0.0.0
 network 12.0.0.0
 network 22.0.0.0
 network 23.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
route-map TEST21 permit 10
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2#

-===


R1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down
Serial0/0                  12.1.1.1        YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/1                  unassigned      YES NVRAM  administratively down down
Loopback0                  1.1.0.1         YES NVRAM  up                    up
Loopback1                  1.1.1.1         YES NVRAM  up                    up
Loopback2                  1.1.2.1         YES NVRAM  up                    up
Loopback3                  1.1.3.1         YES NVRAM  up                    up
R1#
R1#sh run
Building configuration...

Current configuration : 1564 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
key chain RIP_CLEAR_TXT
 key 1
   key-string CISCO123
key chain RIP_MD5
 key 1
   key-string CISCO123
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 1.1.0.1 255.255.255.0
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback2
 ip address 1.1.2.1 255.255.255.0
!
interface Loopback3
 ip address 1.1.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 12.1.1.1 255.255.255.0
 ip rip authentication mode md5
 ip rip authentication key-chain RIP_MD5
 serial restart-delay 0
 clock rate 64000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router rip
 version 2
 network 1.0.0.0
 network 12.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R1#