Friday 13 November 2015

EIGRP offset-list in name mode

Same topology like before in EIGRP-offset-list classic mode , we are increasing the metric to reach
lo0 in R2


R1#
R1#sh ip access-list
Standard IP access list 2
    10 permit 2.2.2.2
R1#
R1#sh run | s router
router eigrp cisco6
router eigrp cisco
 !
 address-family ipv4 unicast autonomous-system 100
  !
  topology base _+++++++++++++++note we have to conig everything in topology base
   redistribute connected metric 10000 1 255 1 1500 route-map CONN
   offset-list 2 in 300 Serial2/0
   offset-list 2 in 300 Serial2/2
  exit-af-topology
  network 192.168.12.0
  network 192.168.21.0
 exit-address-family


This is before we applied the offset-list

R1(config-router-af)#do sh ip eigrp topo
EIGRP-IPv4 VR(cisco) Topology Table for AS(100)/ID(10.10.60.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.23.0/24, 2 successors, FD is 3045896258
        via 192.168.12.2 (3045896258/1735176258), Serial2/0
        via 192.168.21.1 (3045896258/1735176258), Serial2/2
P 192.168.21.0/24, 1 successors, FD is 1735175958
        via Connected, Serial2/2
P 10.10.110.0/24, 2 successors, FD is 3374344258
        via 192.168.12.2 (3374344258/2063624258), Serial2/0
        via 192.168.21.1 (3374344258/2063624258), Serial2/2
P 192.168.12.0/24, 1 successors, FD is 1735175958
        via Connected, Serial2/0
P 10.10.30.0/24, 1 successors, FD is 66191360
        via Rconnected (66191360/0)
P 10.10.140.0/24, 2 successors, FD is 3374344258
        via 192.168.12.2 (3374344258/2063624258), Serial2/0
        via 192.168.21.1 (3374344258/2063624258), Serial2/2
P 10.10.150.0/24, 2 successors, FD is 3374344258
        via 192.168.12.2 (3374344258/2063624258), Serial2/0
        via 192.168.21.1 (3374344258/2063624258), Serial2/2
P 2.2.2.0/24, 2 successors, FD is 2062856258 <+++++++before after  2062855958
        via 192.168.12.2 (2062856258/327762220), Serial2/0
        via 192.168.21.1 (2062856258/327762220), Serial2/2
P 10.10.60.0/24, 1 successors, FD is 66191360, tag is 60
        via Rconnected (66191360/0)
P 192.168.32.0/24, 2 successors, FD is 3901440300
        via 192.168.12.2 (3901440300/2590720300), Serial2/0
        via 192.168.21.1 (3901440300/2590720300), Serial2/2
P 10.10.20.0/24, 1 successors, FD is 66191360
        via Rconnected (66191360/0)
P 10.10.40.0/24, 1 successors, FD is 66191360
        via Rconnected (66191360/0)
P 10.10.130.0/24, 2 successors, FD is 3374344258
        via 192.168.12.2 (3374344258/2063624258), Serial2/0
        via 192.168.21.1 (3374344258/2063624258), Serial2/2
P 3.3.3.3/32, 2 successors, FD is 3374344258
        via 192.168.12.2 (3374344258/2063624258), Serial2/0
        via 192.168.21.1 (3374344258/2063624258), Serial2/2
P 10.1.1.0/30, 1 successors, FD is 66191360
        via Rconnected (66191360/0)
P 10.10.10.0/24, 1 successors, FD is 66191360
        via Rconnected (66191360/0)
P 1.1.1.1/32, 1 successors, FD is 66191360
        via Rconnected (66191360/0)
P 10.10.50.0/24, 1 successors, FD is 66191360
        via Rconnected (66191360/0)
P 10.10.120.0/24, 2 successors, FD is 3374344258
        via 192.168.12.2 (3374344258/2063624258), Serial2/0
        via 192.168.21.1 (3374344258/2063624258), Serial2/2

R1(config-std-nacl)#permit host 2.2.2.2R1(config-std-nacl)#exit
R1(config)#d sh ip eigrp topo
*Nov 13 17:38:54.956: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.12.2 (Serial2/0) is resync: intf route configuration changed
*Nov 13 17:38:54.956: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.21.1 (Serial2/2) is resync: intf route configuration changed

R1(config)#do sh ip eigrp topo | b 2.2.2.0
P 2.2.2.0/24, 2 successors, FD is 2062855958 +++++++++++++300 ADDED
        via 192.168.12.2 (2062855958/327761920), Serial2/0
        via 192.168.21.1 (2062855958/327761920), Serial2/2
P 10.10.60.0/24, 1 successors, FD is 66191360, tag is 60
        via Rconnected (66191360/0)
P 192.168.32.0/24, 2 successors, FD is 3901440000
        via 192.168.12.2 (3901440000/2590720000), Serial2/0
        via 192.168.21.1 (3901440000/2590720000), Serial2/2
P 10.10.20.0/24, 1 successors, FD is 66191360
        via Rconnected (66191360/0)
P 10.10.40.0/24, 1 successors, FD is 66191360
        via Rconnected (66191360/0)
P 10.10.130.0/24, 2 successors, FD is 3374343958
        via 192.168.12.2 (3374343958/2063623958), Serial2/0
        via 192.168.21.1 (3374343958/2063623958), Serial2/2
P 3.3.3.3/32, 2 successors, FD is 3374343958
        via 192.168.12.2 (3374343958/2063623958), Serial2/0
        via 192.168.21.1 (3374343958/2063623958), Serial2/2
P 10.1.1.0/30, 1 successors, FD is 66191360
        via Rconnected (66191360/0)
P 10.10.10.0/24, 1 successors, FD is 66191360
        via Rconnected (66191360/0)
P 1.1.1.1/32, 1 successors, FD is 66191360

R1(config)#sh run

EIGRP offset-list


This another method to influence the metric in a routing protocol. The offset-list lets you increase the metric when you send a routing update to your neighbor or when you receive it.
You can use this for RIP or EIGRP, it is not supported for OSPF.

In this example wewill show how we can increase the metric







 lo01.1.1.1      lo02.2.2.2
R1 ========R2===========R3 (loopback 3.3.3.3)


R2#sh ip eigrp topo
P 10.10.130.0/24, 1 successors, FD is 2297856
        via 192.168.23.3 (2297856/128256), Serial2/1
        via 192.168.32.3 (5639936/128256), Ethernet0/1
P 3.3.3.3/32, 1 successors, FD is 2297856 ++++++++++++++
        via 192.168.23.3 (2297856/128256), Serial2/1
        via 192.168.32.3 (5639936/128256), Ethernet0/1
P 10.1.1.0/30, 2 successors, FD is 2195456
        via 192.168.12.1 (2195456/281600), Serial2/0
        via 192.168.21.2 (2195456/281600), Serial2/2
P 10.10.10.0/24, 2 successors, FD is 2297856
        via 192.168.12.1 (2297856/128256), Serial2/0
        via 192.168.21.2 (2297856/128256), Serial2/2


We introduce in router R2 a offset-list to reach 3.3.3.3


R2(config)#ip access-list standard 2
R2(config-std-nacl)#permit host 3.3.3.3

R2(config-std-nacl)#
R2(config-std-nacl)#end
R2#

R2(config)#router eigrp 100
R2(config-router)#off
R2(config-router)#offset-list 1 ?
  in   Perform offset on incoming updates
  out  Perform offset on outgoing updates

R2(config-router)#offset-list 1 in 300 se2/1
R2(config-router)#offset-list 1 out 300 se2/1

after
R2(config-router)#do sh ip eigrp topology | b 3.3.3.3
P 3.3.3.3/32, 1 successors, FD is 2298156 _++++++++++++++++++++
        via 192.168.23.3 (2298156/128512), Serial2/1
        via 192.168.32.3 (5639936/128256), Ethernet0/1
P 10.1.1.0/30, 2 successors, FD is 2195456
        via 192.168.12.1 (2195456/281600), Serial2/0
        via 192.168.21.2 (2195456/281600), Serial2/2
P 10.10.10.0/24, 2 successors, FD is 2297856
        via 192.168.12.1 (2297856/128256), Serial2/0
        via 192.168.21.2 (2297856/128256), Serial2/2
P 1.1.1.1/32, 2 successors, FD is 2170112
        via 192.168.12.1 (2170112/256256), Serial2/0
        via 192.168.21.2 (2170112/256256), Serial2/2
P 10.10.50.0/24, 2 successors, FD is 2297856
        via 192.168.12.1 (2297856/128256), Serial2/0
        via 192.168.21.2 (2297856/128256), Serial2/2
P 10.10.120.0/24, 1 successors, FD is 2298156
        via 192.168.23.3 (2298156/128512), Serial2/1
        via 192.168.32.3 (5639936/128256), Ethernet0/1

R2(config-router)#

Wednesday 4 November 2015

EGRP name mode

This gives you glimpse of EIGRP name mode configuration.

In traditional way we were configuring EIGRP like this,

We go to configuration mode and defining EIGRP with process number

R1#conf t
R1(config)#router eigrp 1
R1(config-router)#

After that if we have to run EIGRP on the interfaces then we have to specify each network with wildcard mask for every interface:

R1(config-router)#network 10.1.1.0 0.0.0.3
R1(config-router)#network 1.1.1.1 0.0.0.0


And for some the command like EIGRP authentication, defining Bandwidth to control EIGRP packets or to define EIGRP next-hop you have exit Router config mode and switch to interface mode as shown below:

R1(config-router)#exit
R1(config)#int fa0/0
R1(config-if)#ip authentication mode eigrp 1 md5
R1(config-if)#ip authentication key-chain eigrp 1 cisco
R1(config-if)#ip bandwidth-percent eigrp 1 75

This was what we discussed for IPv4 Eigrp. Now to run EIGRP for IPv6 we have to configure in different way define the IPv6 router process and run Eigrp under interface mode.

ipv6 router eigrp 1
eigrp router-id 10.1.1.1
no shut
!
Interface f0/0
ipv6 enabe
ipv6 eigrp 1
!

So In traditional way for every address family (IPv4/VRF/IPv6) you have to configure EIGRP separately .You have to switch config mode to interface mode, also another interesting point is that there was no way to configure VRF in traditional IPv6 EIGRP implementation but in “EIGRP Name Mode configuration” you can config all in one place, plus you have the option to run IPv6 Eigrp for VRF

Let’s discussed EIGRP name mode configuration in detail.

EIGRP named configuration is available in following IOS release and onwards:

15.0(1)M

12.2(33)SRE

12.2(33)XNE

Cisco IOS XE Release 2.5

If you are running any of the above IOS versions then you will see 2 options after you do question mark as shown. 

R2(config)#router eigrp ?
  <1-65535> Autonomous System
  WORD       EIGRP Virtual-Instance Name

To define Name mode configuration define word option as show below:

R2(config)#router eigrp CISCO

Unlike traditional way, EIGRP instance not create or it doesn't start running the moment following is configured on the router. The instance will be created when address-family and autonomous system number is configured for e.g.:


For IPv4:

R2(config-router)#address-family ipv4 unicast autonomous-system 1

For IPv4 VRF:

R2(config-router)#address-family ipv4 unicast vrf Customer_A autonomous-system 1

For IPv6:

R2(config-router)#address-family ipv6 unicast autonomous-system 1

For IPv6 VRF

R2(config-router)#address-family ipv6 unicast vrf site_A autonomous-system 1

With this Named mode, we can create a single Instance of EIGRP, which can be used for all address family type as shown above.
Another simplicity is if want to turn off the entire AS, you can use “shutdown” command under address-family to turn off the entire instance.


Named EIGRP has 3 configuration modes. These are:

    1) address-family configuration mode - (config-router-af)#
    2) address-family interface configuration mode - (config-router-af-interface)#
    3) address-family topology configuration mode - (config-router-af-topology)#

A) Address-family configuration mode:

In this mode, you can configure networks, EIGRP neighbor, EIGRP Router-id, metric etc. From this mode you can access the other two configuration modes used in EIGRP named configuration.

R2(config-router)#address-family ipv4 unicast autonomous-system 1
R2(config-router-af)#?
Address Family configuration commands:
  af-interface         Enter Address Family interface configuration
  default              Set a command to its defaults
  eigrp                EIGRP Address Family specific commands
  exit-address-family  Exit Address Family configuration mode
  help                 Description of the interactive help system
  maximum-prefix       Maximum number of prefixes acceptable in aggregate
  metric               Modify metrics and parameters for address advertisement
  neighbor             Specify an IPv4 neighbor router
  network              Enable routing on an IP network
  no                   Negate a command or set its defaults
  shutdown             Shutdown address family
  timers               Adjust peering based timers
  topology             Topology configuration mode

R2(config-router-af)#

B) Address-family interface configuration mode:

This mode takes all the interface specific commands that were previously configured on an actual interface (logical or physical) and moves them into the EIGRP configuration. EIGRP authentication, Bandwidth-percentage, split-horizon, and summary-address configuration are some of the options that are now configured here instead of in interface configuration mode.

R2(config-router-af)#af-interface fa0/0
R2(config-router-af-interface)#?
Address Family Interfaces configuration commands:
  authentication      authentication subcommands
  bandwidth-percent   Set percentage of bandwidth percentage limit
  bfd                 Enable Bidirectional Forwarding Detection
  dampening-change    Percent interface metric must change to cause update
  dampening-interval  Time in seconds to check interface metrics
  default             Set a command to its defaults
  exit-af-interface   Exit from Address Family Interface configuration mode
  hello-interval      Configures hello interval
  hold-time           Configures hold time
  next-hop-self       Configures EIGRP next-hop-self
  no                  Negate a command or set its defaults
  passive-interface   Suppress address updates on an interface
  shutdown            Disable Address-Family on interface
  split-horizon       Perform split horizon
  summary-address     Perform address summarization

R2(config-router-af-interface)#

In traditional way if we want run EIGRP on all interface we use "network 0.0.0.0 0.0.0.0" command. Here you can use “af-interface default” to function same.

R2(config-router-af)#af-interface default
R2(config-router-af-interface)#

C) Address-family topology configuration mode:

This mode provide several options which operates on EIGRP topology table .here you can define content like redistribution, distance, offset list, variance etc. To enter this mode, we need to go back to address-family configuration mode:

R2(config-router-af-interface)#exit
R2(config-router-af)#topology base
R2(config-router-af-topology)#?
Address Family Topology configuration commands:
  auto-summary         Enable automatic network number summarization
  default              Set a command to its defaults
  default-information  Control distribution of default information
  default-metric       Set metric of redistributed routes
  distance             Define an administrative distance
  distribute-list      Filter entries in eigrp updates
  eigrp                EIGRP specific commands
  exit-af-topology     Exit from Address Family Topology configuration mode
  fast-reroute         Configure Fast-Reroute
  maximum-paths        Forward packets over multiple paths
  metric               Modify metrics and parameters for advertisement
  no                   Negate a command or set its defaults
  offset-list          Add or subtract offset from EIGRP metrics
  redistribute         Redistribute IPv4 routes from another routing protocol
  snmp                 Modify snmp parameters
  summary-metric       Specify summary to apply metric/filtering
  timers               Adjust topology specific timers
  traffic-share        How to compute traffic share over alternate paths
  variance             Control load balancing variance

R2(config-router-af-topology)#

Comparison chart between Eigrp “traditional Configuration” and “Name mode Configuration”:

EIGRP Tradition way of ConfigurationEIGRP Name Mode Configuration
int fa0/0
ip add 10.1.1.1 255.255.255.252
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 cisco
ip bandwidth-percent eigrp 1 75 
ip hello eigrp 1 10
IPv6 enable
IPv6 eigrp 1




router eigrp 1
network 10.1.1.0 0.0.0.3
redistribute connected


ipv6 router eigrp 1
eigrp router-id 10.1.1.1
no shut


router eigrp 2
address-family ipv4 vrf CUST_A
network 0.0.0.0 0.0.0.0


"No IPv6 EIGRP support for VRF"
int fa0/0
ip add 10.1.1.1 255.255.255.252
IPv6 enable


router eigrp CISCO
!
address-family ipv6 unicast autonomous-system 1
  !
  topology base
  exit-af-topology
  eigrp router-id 1.1.1.1
exit-address-family
!
address-family ipv4 unicast autonomous-system 1
  !
  af-interface FastEthernet0/0
   authentication mode md5
   authentication key-chain cisco
   bandwidth-percent 75
   hello-interval 10
  exit-af-interface
  !
  topology base
   redistribute connected
  exit-af-topology
exit-address-family
!
address-family ipv6 unicast vrf CUST_B autonomous-system 2
  !
  topology base
  exit-af-topology
exit-address-family
!
address-family ipv4 unicast vrf CUST_A autonomous-system 2
  !
af-interface default
!
  topology base
  exit-af-topology
exit-address-family














Thursday 29 October 2015

Ripv2 triggered






Sample Configuration of Triggered Extensions to RIP

Contents

Introduction

This document shows sample configurations using the ip rip triggered interface configuration command.
Triggered extensions to Routing Information Protocol (RIP) increase efficiency on point-to-point, serial links. This feature is supported on all platforms running Cisco IOS® Software Release 12.0(1)T and higher. Triggered extensions help avoid two common problems with using RIP to connect to a WAN:
  • Periodic broadcasting by RIP can prevent WAN circuits from being closed.
  • Even on fixed, point-to-point links, the overhead of periodic RIP transmissions can seriously interrupt normal data transfer.
To enable this feature, use the ip rip triggered interface configuration command on both the sides of the link. See the configurations below for an example.

Prerequisites

Requirements

There are no specific requirements for this document.

Configure

In this section, you are presented with the information to configure the features described in this document.
) .

Network Diagram

This document uses the network setup shown in the diagram below.
51a.gif

Configurations

This document uses the configurations shown below.

S3-3640
interface Serial1/0 
  ip address 172.16.1.1 255.255.255.0
  ip rip triggered
 ! 
 router rip
  network 172.16.0.0 

S3-3620
interface Loopback8
 ip address 172.19.1.1 255.255.255.0
!
interface Ethernet0/3
 ip address 172.18.1.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.0
 ip rip triggered
!
router rip
 network 172.16.0.0
 network 172.18.0.0
 network 172.19.0.0

Verify

This section provides information you can use to confirm your configuration is working properly.
Routes learned by an interface that is configured with ip rip triggered is shown as a permanent entry in the RIP database and routing table.

  • show ip route - Displays the current state of the routing table.
  • show ip rip database - Displays summary address entries in the RIP routing database entries if relevant routes are being summarized based upon a summary address.
S3-3640#show ip route
C       172.16.1.0/24 is directly connected, Serial1/0
R    172.19.0.0/16 [120/1] via 172.16.1.2, Serial1/0
R    172.18.0.0/16 [120/1] via 172.16.1.2, Serial1/0

S3-3640#show ip rip database
172.18.0.0/16    auto-summary
172.18.0.0/16
    [1] via 172.16.1.2, 00:02:44 (permanent), Serial1/0
 * Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0
172.19.0.0/16    auto-summary
172.19.0.0/16
    [1] via 172.16.1.2, 00:02:45 (permanent),Serial1/0
   * Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands


  • debug ip rip events - Displays information on RIP routing transactions.
S3-3640#debug ip rip events
RIP: received v1 triggered request from 172.16.1.2 on Serial1/0
RIP: start retransmit timer of 172.16.1.2
RIP: received v1 triggered ack from 172.16.1.2 on Serial1/0
RIP: Stopped retrans timer for 172.16.1.2
RIP: sending v1 ack to 172.16.1.2 via Serial1/0 (172.16.1.1),

Conclusion

When you enable triggered extensions to RIP, routing updates are transmitted on the WAN only if one of the following events occurs:
  • The router receives a specific request for a routing update, which causes the full database to be sent.
  • Information from another interface modifies the routing database, which causes only the latest changes to be sent.
  • The interface comes up or goes down, which causes a partial database to be sent.
  • The router is powered on for the first time to ensure that at least one update is sent, which causes the full database to be sent. 

Triggered Updates

Triggered updates allow a RIP router to announce changes in metric values almost immediately rather than waiting for the next periodic announcement. The trigger is a change to a metric in an entry in the routing table. For example, networks that become unavailable can be announced with a hop count of 16 through a triggered update. Note that the update is sent almost immediately , where a time interval to wait is typically specified on the router. If triggered updates were sent by all routers immediately, each triggered update could cause a cascade of broadcast traffic across the IP internetwork.
Triggered updates improve the convergence time of RIP internetworks but at the expense of additional broadcast traffic as the triggered updates are propagated.


Tuesday 27 October 2015

RIP Timers

RIP Timers

 Even the command to set them is named timers basic… However in some documentation it is not really clear what the difference is between the invalid and holddown timer.

The default timers are 30 for updates, 180 for invalid, 180 for holddown and 240 for flush.

 I have heard and seen described in official documentation that when a route is in holddown it will not accept routes with a worse metric but routes with a better metric. This is however not true. First lets describe the different timers.


  • Updates – Updates are sent every 30 seconds by default to the address 224.0.0.9.
  • Invalid – If there has not been any updates for 180 seconds about the prefix it is consider invalid and the route will be poisoned (route advertised with a metric of 16).
  • Holddown – The timer for holddown will be activated when the route goes into an invalid state. This is set to 180 by default.
  • Flush – This timer is set to 240 seconds, when a routes is 240 seconds old it is flushed from the routing table.
So the holddown timer is used to stabilize the topology, even better routes will be suppressed which is not what some documentation says. Here is how we will tested it.


 We will created a topology with 3 routers connecting to each other and both the routers announced 1.1.1.1/32 to the middle router. We created an ACL on the middle router to filter all traffic so that the best route will become invalid. On the third router we used an offset-list to make the route worse. After the route became invalid we stopped sending the route with a worse metric and sent it with a better metric. However the route is still not installed until the holddown timer has expired. If you manipulate the timers it is easier to see. We used 5 seconds for updates, 30 for invalid, 30 for holddown and flush of 240. You will see that it takes 60s before the route gets installed.
If you use the standard timers the holddown timer will not expire before the route is flushed since the 180 seconds start counting after 180s by default and then there is only 60s left until the route is flushed. Try this out for yourself and see if you get the same results as I.

timers basic

To adjust Routing Information Protocol (RIP) network timers, use the timers basic command in router configuration mode. To restore the default timers, use the no form of this command.
timers basic update invalid holddown flush
no timers basic

Syntax Description


update
Rate (in seconds) at which updates are sent. This is the fundamental timing parameter of the routing protocol. The default is 30 seconds.
invalid
Interval of time (in seconds) after which a route is declared invalid. The interval should be at least three times the value of update time. The interval is measured from the last update received for the route. The route becomes invalid when there is an absence of updates during the invalid time that refresh the route. The route is marked inaccessible and advertised as unreachable. However, the route still forwards packets until the flush interval expires. The default is 180 seconds.
holddown
Interval (in seconds) during which routing information regarding better paths is suppressed. The interval should be at least three times the value of update time. A route enters into a holddown state when an update packet is received that indicates the route is unreachable. The route is marked inaccessible and advertised as unreachable. However, the route continues to forward packets until an update is received with a better metric or until the holddown time expires. When the holddown expires, routes advertised by other sources are accepted and the route is no longer inaccessible. The default is 180 seconds.
flush
Amount of time (in seconds) that must pass before the route is removed from the routing table. The interval is measured from the last update received for the route. The interval should be longer than the larger of the invalid and holddown values. If the interval is less than the sum of the update and holddown values, the proper holddown interval cannot elapse, which results in a new route being accepted before the holddown interval expires. The default is 240 seconds.

Defaults

update: 30 seconds
invalid: 180 seconds
holddown: 180 seconds
flush: 240 seconds

Command Modes

Router configuration

Command History


Release
Modification
10.0
This command was introduced.

Usage Guidelines

The basic timing parameters for RIP are adjustable. Because RIP is executing a distributed, asynchronous routing algorithm, these timers must be the same for all routers and access servers in the network.

Note The current and default timer values can be seen by inspecting the output of the show ip protocols EXEC command. The relationships of the various timers should be preserved as described previously.

Examples

The following example sets updates to be broadcast every 5 seconds. If a router is not heard from in 15 seconds, the route is declared unusable. Further information is suppressed for an additional 15 seconds. At the end of the suppression period, the route is flushed from the routing table.
router rip
 timers basic 5  15  15  30