IPv6 Automatic 6to4 Tunnels
This feature provides support for IPv6 automatic 6to4 tunnels. An
automatic 6to4 tunnel allows isolated IPv6 domains to be connected over
an IPv4 network to remote IPv6 networks.
Finding Feature Information
Your software release may not support all the features
documented in this module. For the latest caveats and feature
information, see
Bug Search Tool
and the release notes for your platform and software release. To find
information about the features documented in this module, and to see a
list of the releases in which each feature is supported, see the feature
information table at the end of this module.
Use Cisco Feature Navigator to find information about platform
support and Cisco software image support. To access Cisco Feature
Navigator, go to
www.cisco.com/go/cfn. An account on Cisco.com is not required.
Information About IPv6 Automatic 6to4 Tunnels
Automatic 6to4 Tunnels
An automatic 6to4 tunnel allows isolated IPv6 domains to be
connected over an IPv4 network to remote IPv6 networks. The key
difference between automatic 6to4 tunnels and manually configured
tunnels is that the tunnel is not point-to-point; it is
point-to-multipoint. In automatic 6to4 tunnels, routers are not
configured in pairs because they treat the IPv4 infrastructure as a
virtual nonbroadcast multiaccess (NBMA) link. The IPv4 address embedded
in the IPv6 address is used to find the other end of the automatic
tunnel.
An automatic 6to4 tunnel may be configured on a border router in an
isolated IPv6 network, which creates a tunnel on a per-packet basis to a
border router in another IPv6 network over an IPv4 infrastructure. The
tunnel destination is determined by the IPv4 address of the border
router extracted from the IPv6 address that starts with the prefix
2002::/16, where the format is 2002:border-router-IPv4-address
::/48. Following the embedded IPv4 address are 16 bits that can be used
to number networks within the site. The border router at each end of a
6to4 tunnel must support both the IPv4 and IPv6 protocol stacks. 6to4
tunnels are configured between border routers or between a border router
and a host.
The simplest deployment scenario for 6to4 tunnels is to interconnect
multiple IPv6 sites, each of which has at least one connection to a
shared IPv4 network. This IPv4 network could be the global Internet or a
corporate backbone. The key requirement is that each site have a
globally unique IPv4 address; the Cisco software uses this address to
construct a globally unique 6to4/48 IPv6 prefix. As with other tunnel
mechanisms, appropriate entries in a Domain Name System (DNS) that map
between hostnames and IP addresses for both IPv4 and IPv6 allow the
applications to choose the required address.
How to Configure IPv6 Automatic 6to4 Tunnels
Configuring Automatic 6to4 Tunnels
Before You Begin
With 6to4 tunnels, the tunnel destination is determined by the border
router IPv4 address, which is concatenated to the prefix 2002::/16 in
the format 2002: border-router-IPv4-address
::/48. The border router at each end of a 6to4 tunnel must support both the IPv4 and IPv6 protocol stacks.
Note |
The configuration of only one IPv4-compatible tunnel and one 6to4 IPv6
tunnel is supported on a router. If you choose to configure both of
those tunnel types on the same router, we strongly recommend that they
do not share the same tunnel source.
The reason that a 6to4 tunnel and an IPv4-compatible tunnel cannot share
an interface is that both of them are NBMA "point-to-multipoint" access
links and only the tunnel source can be used to reorder the packets
from a multiplexed packet stream into a single packet stream for an
incoming interface. So when a packet with an IPv4 protocol type of 41
arrives on an interface, that packet is mapped to an IPv6 tunnel
interface based on the IPv4 address. However, if both the 6to4 tunnel
and the IPv4-compatible tunnel share the same source interface, the
router is not able to determine the IPv6 tunnel interface to which it
should assign the incoming packet.
IPv6 manually configured tunnels can share the same source interface
because a manual tunnel is a "point-to-point" link, and both the IPv4
source and IPv4 destination of the tunnel are defined.
>
|
SUMMARY STEPS
1.
enable
2.
configure
terminal
3.
interface
tunnel
tunnel-number
4.
ipv6
address
{ipv6-address / prefix-length | prefix-name sub-bits/prefix-length
5.
tunnel
source
{ip-address| interface-t ype interface-number}
6.
tunnel
mode
ipv6ip
[6rd | 6to4 | auto-tunnel | isatap
7.
exit
8.
ipv6
route
[vrf vrf-name] ipv6-prefix / prefix-length{ipv6-address | interface-type interface-number [ipv6-address]} [nexthop-vrf [vrf-name1 | default]] [administrative-distance] [administrative-multicast-distance | unicast | multicast] [next-hop-address] [tag tag]
DETAILED STEPS
| Command or Action | Purpose |
Step 1 |
enable
Example:
|
Enables privileged EXEC mode.
-
Enter your password if prompted.
|
Step 2 |
configure
terminal
Example:
Router# configure terminal
|
Enters global configuration mode.
|
Step 3 |
interface
tunnel
tunnel-number
Example:
Router(config)# interface tunnel 1
|
Specifies a tunnel interface and number, and enters interface configuration mode.
|
Step 4 |
ipv6
address
{ipv6-address / prefix-length | prefix-name sub-bits/prefix-length
Example:
Router(config-if)# ipv6 address 3ffe:b00:c18:1::3/127
|
Specifies the IPv6 network assigned to the interface and enables IPv6 processing on the interface.
|
Step 5 |
tunnel
source
{ip-address| interface-t ype interface-number}
Example:
Router(config-if)# tunnel source loopback 1
|
Specifies the source interface type and number for the tunnel interface.
|
Step 6 |
tunnel
mode
ipv6ip
[6rd | 6to4 | auto-tunnel | isatap
Example:
Router(config-if)# tunnel mode ipv6ip 6rd
|
Configures a static IPv6 tunnel interface.
-
The auto-tunnel keyword is not supported on Cisco ASR 1000 series routers.
|
Step 7 |
exit
Example:
|
Exits interface configuration mode, and enters global configuration mode.
|
Step 8 |
ipv6
route
[vrf vrf-name] ipv6-prefix / prefix-length{ipv6-address | interface-type interface-number [ipv6-address]} [nexthop-vrf [vrf-name1 | default]] [administrative-distance] [administrative-multicast-distance | unicast | multicast] [next-hop-address] [tag tag]
Example:
Router(config)# ipv6 route 2002::/16 tunnel 0
|
Configures a static route for the IPv6 6to4 prefix 2002::/16 to the specified tunnel interface.
Note
|
When configuring a 6to4 overlay tunnel, you must configure a static
route for the IPv6 6to4 prefix 2002::/16 to the 6to4 tunnel interface.
|
-
The tunnel number specified in the ipv6 route command must be the same tunnel number specified in the interface tunnel command.
|
Configuration Examples for IPv6 Automatic 6to4 Tunnels
Example: Configuring 6to4 Tunnels
The following example configures a 6to4 tunnel on a border router
in an isolated IPv6 network. The IPv4 address is 192.168.99.1, which
translates to the IPv6 prefix of 2002:c0a8:6301::/48. The IPv6 prefix is
subnetted into 2002:c0a8:6301::/64 for the tunnel interface:
2002:c0a8:6301:1::/64 for the first IPv6 network, and
2002:c0a8:6301:2::/64 for the second IPv6 network. The static route
ensures that any other traffic for the IPv6 prefix 2002::/16 is directed
to tunnel interface 0 for automatic tunneling.
interface GigabitEthernet0/0/0
description IPv4 uplink
ip address 192.168.99.1 255.255.255.0
!
interface GigabitEthernet1/0/0
description IPv6 local network 1
ipv6 address 2002:c0a8:6301:1::1/64
!
interface GigabitEthernet2/0/0
description IPv6 local network 2
ipv6 address 2002:c0a8:6301:2::1/64
!
interface Tunnel0
description IPv6 uplink
no ip address
ipv6 address 2002:c0a8:6301::1/64
tunnel source GigabitEthernet0/0/0
tunnel mode ipv6ip 6to4
!
ipv6 route 2002::/16 tunnel 0
Additional References
Standards and RFCs
Standard/RFC
|
Title
|
RFCs for IPv6
|
IPv6 RFCs
|
MIBs
MIB
|
MIBs Link
|
|
To locate and download MIBs for selected platforms, Cisco IOS
releases, and feature sets, use Cisco MIB Locator found at the following
URL:
http://www.cisco.com/go/mibs
|
Technical Assistance
Description
|
Link
|
The Cisco Support and Documentation website provides online
resources to download documentation, software, and tools. Use these
resources to install and configure the software and to troubleshoot and
resolve technical issues with Cisco products and technologies. Access to
most tools on the Cisco Support and Documentation website requires a
Cisco.com user ID and password.
|
http://www.cisco.com/cisco/web/support/index.html
|
Feature Information for IPv6 Automatic 6to4 Tunnels
The following table provides release information about the feature
or features described in this module. This table lists only the software
release that introduced support for a given feature in a given software
release train. Unless noted otherwise, subsequent releases of that
software release train also support that feature.
Use Cisco Feature Navigator to find information about platform
support and Cisco software image support. To access Cisco Feature
Navigator, go to
www.cisco.com/go/cfn. An account on Cisco.com is not required.
Table 1 Feature Information for IPv6 Automatic 6to4 Tunnels
Feature Name
|
Releases
|
Feature Information
|
IPv6 Tunneling: Automatic 6to4 Tunnels
|
Cisco IOS XE Release 2.1
|
An automatic 6to4 tunnel allows isolated IPv6 domains to be connected over an IPv4 network to remote IPv6 networks.
The following commands were introduced or modified:
tunnel mode ipv6ip,
tunnel source.
|
|