EIGRPv6 using INE config
This is an example of EIGRPv6 simulated on WEB-IOU.
the sw11 is configured to create the cloud
SW#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active
100 VLAN0100 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
100 enet 100100 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
SW#
SW#sh run int e0/1 | b int
interface Ethernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
duplex auto
end
SW#sh run int e0/2 | b int
interface Ethernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
duplex auto
end
SW#sh run int e0/3 | b int
interface Ethernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
duplex auto
end
SW#
R1 configuration
R1#sh run | inc ipv6 unicast
ipv6 unicast-routing
R1#sh run int e0/1.100 | b int
interface Ethernet0/1.100
encapsulation dot1Q 100
ip address 169.254.100.1 255.255.255.0
ipv6 address 2001:169:254:100::1/64
end
R1#
R1#
R1#
sh run | inc ipv6 unicast
sh run int e0/1.100 | b int
sh run int tun0 | b int
!
!
interface Tunnel0
ip address 155.1.0.1 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication NHRPPASS
ip nhrp map 155.1.0.5 169.254.100.5
ip nhrp map multicast 169.254.100.5
ip nhrp network-id 1
ip nhrp holdtime 300
ip nhrp nhs 155.1.0.5
ip tcp adjust-mss 1360
ipv6 address 2001:155:100::1/64
ipv6 eigrp 100
ipv6 nhrp authentication CISCO
ipv6 nhrp map multicast 169.254.100.5
ipv6 nhrp map 2001:155:100::5/64 169.254.100.5
ipv6 nhrp network-id 99
ipv6 nhrp nhs 2001:155:100::5
tunnel source Ethernet0/1.100
tunnel mode gre multipoint
tunnel key 100000
tunnel protection ipsec profile DMVPN_PROFILE
!
R2#sh run | inc ipv6 unicast
ipv6 unicast-routing
R2#sh run int e0/1.100 | b int
interface Ethernet0/1.100
encapsulation dot1Q 100
ip address 169.254.100.2 255.255.255.0
ipv6 address 2001:169:254:100::2/64
end
R2# configuration
interface Tunnel0
ip address 155.1.0.2 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication NHRPPASS
ip nhrp map 155.1.0.5 169.254.100.5
ip nhrp map multicast 169.254.100.5
ip nhrp network-id 1
ip nhrp holdtime 300
ip nhrp nhs 155.1.0.5
ip tcp adjust-mss 1360
ip ospf network non-broadcast
ip ospf priority 0
ipv6 address 2001:155:100::2/64
ipv6 eigrp 100
ipv6 nhrp authentication CISCO
ipv6 nhrp map 2001:155:100::5/64 169.254.100.5
ipv6 nhrp map multicast 169.254.100.5
ipv6 nhrp network-id 99
ipv6 nhrp nhs 2001:155:100::5
tunnel source Ethernet0/1.100
tunnel mode gre multipoint
tunnel key 100000
tunnel protection ipsec profile DMVPN_PROFILE
end
R2#
R5 HUB configuration
R5#sh run int tu0
Building configuration...
Current configuration : 508 bytes
!
interface Tunnel0
ip address 155.1.0.5 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication NHRPPASS
ip nhrp map multicast dynamic
ip nhrp network-id 1
ip tcp adjust-mss 1360
ip ospf network non-broadcast
delay 1000
ipv6 address 2001:155:100::5/64
ipv6 eigrp 100
ipv6 nhrp authentication CISCO
ipv6 nhrp map multicast dynamic
ipv6 nhrp network-id 99
tunnel source Ethernet0/1.100
tunnel mode gre multipoint
tunnel key 100000
tunnel protection ipsec profile DMVPN_PROFILE
end
R5#
from hub router
R5#show ipv route eigrp
IPv6 Routing Table - default - 14 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, ls - LISP site
ld - LISP dyn-EID, a - Application
D 2001:150:1:1::1/128 [90/25984000]
via FE80::A8BB:CCFF:FE00:100, Tunnel0
D 2001:150:2:2::2/128 [90/25984000]
via FE80::A8BB:CCFF:FE00:200, Tunnel0
R5#
from spoke
R2(config-if)#do sh ipv route eigrp
IPv6 Routing Table - default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, ls - LISP site
ld - LISP dyn-EID, a - Application
D 2001:150:5:5::5/128 [90/27008000]
via FE80::A8BB:CCFF:FE00:500, Tunnel0
R1#sh ipv6 route eigrp
IPv6 Routing Table - default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, ls - LISP site
ld - LISP dyn-EID, a - Application
D 2001:150:5:5::5/128 [90/27008000]
via FE80::A8BB:CCFF:FE00:500, Tunnel0
disable split-horiziont in the hub
R5#config t
R5(config-t)#int tu0
R5(config-if)#no ipv6 split
R2# sh ipv route eigrp
IPv6 Routing Table - default - 12 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, ls - LISP site
ld - LISP dyn-EID, a - Application
D 2001:150:1:1::1/128 [90/27264000]
via FE80::A8BB:CCFF:FE00:500, Tunnel0
D 2001:150:5:5::5/128 [90/27008000]
via FE80::A8BB:CCFF:FE00:500, Tunnel0
R2#
R2#
R1#sh ipv route eigrp
IPv6 Routing Table - default - 12 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, ls - LISP site
ld - LISP dyn-EID, a - Application
D 2001:150:2:2::2/128 [90/27264000]
via FE80::A8BB:CCFF:FE00:500, Tunnel0
D 2001:150:5:5::5/128 [90/27008000]
via FE80::A8BB:CCFF:FE00:500, Tunnel0
R1#
now we will enable authentication
in all the routers create the key in config mode
R2(config-if)#do sh run | s key
key chain EIGRPV6
key 1
key-string CISCO
and
inside the tunnel0 add these
ipv6 authentication mode eigrp 100 md5
ipv6 authentication key-chain eigrp 100 EIGRPV6
testing
R5#sh ipv eigrp 100 neighbors
EIGRP-IPv6 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 Link-local address: Tu0 12 00:03:36 28 5000 0 9
FE80::A8BB:CCFF:FE00:200
0 Link-local address: Tu0 13 00:03:36 19 5000 0 9
FE80::A8BB:CCFF:FE00:100
R5#